CSGO Free Europe Queue Matching Issues
Incident Report for FACEIT
Resolved
This incident has been resolved.
Posted Mar 22, 2021 - 16:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2021 - 16:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2021 - 16:10 UTC
Investigating
We are currently investigating this issue.
Posted Mar 22, 2021 - 16:06 UTC
This incident affected: Play.