CSGO Europe Queues - Match Creation Issue
Incident Report for FACEIT
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 22:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2022 - 20:46 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 16, 2022 - 20:25 UTC
Update
We are continuing to investigate this issue.
Posted Nov 16, 2022 - 20:10 UTC
Investigating
We are currently investigating this issue.
Posted Nov 16, 2022 - 19:09 UTC
This incident affected: Play.