Match Rooms Failing to Load
Incident Report for FACEIT
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 17:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2020 - 16:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2020 - 16:45 UTC
Investigating
We are currently investigating this issue.
Posted Nov 18, 2020 - 16:33 UTC
This incident affected: Play.