CSGO - Match Configuring Issues
Incident Report for FACEIT
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 20:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2020 - 19:33 UTC
Investigating
We are currently investigating this issue.
Posted Nov 18, 2020 - 19:24 UTC
This incident affected: Play.