Steam Issues
Incident Report for FACEIT
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 00:20 UTC
Monitoring
We will continue to monitor for Steam Stability and open queues once it is.
Posted Apr 14, 2021 - 18:21 UTC
Investigating
CSGO queues closed
Posted Apr 14, 2021 - 17:15 UTC
This incident affected: Play.