CSGO FREE EU - Match creation issues
Incident Report for FACEIT
Resolved
All back to normal, GLHF
Posted Apr 13, 2021 - 20:01 UTC
Monitoring
We've released a fix for the issue. We're waiting to see if it has worked.
Posted Apr 13, 2021 - 19:56 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Apr 13, 2021 - 19:19 UTC