CSGO Queue Matching Issues
Incident Report for FACEIT
Resolved
This incident has been resolved.
Posted Jan 05, 2021 - 21:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2021 - 21:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 05, 2021 - 21:05 UTC
Investigating
We are currently investigating this issue.
Posted Jan 05, 2021 - 19:55 UTC
This incident affected: Play.