Steam Issues
Incident Report for FACEIT
Resolved
All queues are open and steam is stable.
Posted Apr 07, 2021 - 20:01 UTC
Update
Steam has stabilized we are opening the queues and monitoring.
Posted Apr 07, 2021 - 18:45 UTC
Update
Steam has shown signs of instability again. Queues have been closed.
Posted Apr 07, 2021 - 17:14 UTC
Monitoring
CSGO queues open
Posted Apr 07, 2021 - 16:31 UTC
Identified
CSGO queues closed
Posted Apr 07, 2021 - 15:02 UTC
Investigating
CSGO queues closed
Posted Apr 07, 2021 - 14:53 UTC
This incident affected: Play.