Matchmaking Issues
Incident Report for FACEIT
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 21:09 UTC
Update
Leaderboards are now also up and running and we are monitoring to ensure there is no further issues.
Posted Nov 24, 2020 - 18:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results. We are experiencing continued issues with the ladders/leaderboards. Players may notice delays in processing the matches played. Hubs using Leaderboards as the option to Captain select will need to change to a different option till the issue has been resolved.
Posted Nov 24, 2020 - 16:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 24, 2020 - 16:37 UTC
Investigating
We are currently investigating this issue.
Posted Nov 24, 2020 - 15:50 UTC
This incident affected: Play.