Cloudflare Issues
Incident Report for
FACEIT
Resolved
This incident has been resolved.
Posted
Jun
21
,
2022
-
08:17
UTC
Monitoring
Cloudflare have updated their status to monitoring, the platform should work as expected.
Posted
Jun
21
,
2022
-
07:30
UTC
Investigating
We're currently experiencing an ongoing site issue due to Cloudflare being down, we hope this will be resolved quickly and we sincerely apologise.
Posted
Jun
21
,
2022
-
07:06
UTC
×
Subscribe to Incident
Subscribe to updates for
Cloudflare Issues
via . You'll receive .