Resolved
The AC disconnect issue is fully resolved and all queues are open. We are continuing to monitor the platform.
Monitoring
We have rolled out a fix and are monitoring the situation.
Identified
We have identified the issues and are working on a fix.
Investigating
We're aware of ongoing platform and anti-cheat issues, and queues have been temporarily closed while we work to resolve them.