Monitoring
We have rolled out several fixes and are monitoring the situation.
Our teams will work on fixing the affected (cancelled) matches & results over the weekend.
Thank you for your patience!
Monitoring
We have rolled out a fix and are monitoring the situation.
Investigating
We are aware of issues with the platform.