We have identified the issues and are working on a fix.
Thu, Jul 9, 2026, 11:34 PM
(3 minutes ago)
·
Affected components
Anti Cheat
Updates
Identified
We have identified the issues and are working on a fix.
Thu, Jul 9, 2026, 11:34 PM
Investigating
CS2 Update: After the recent update we identified an issue with players not being able to move their mouse while using the FACEIT AC. We are investigating the issue.