Server selection issues
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Thu, Jan 8, 2026, 02:08 PM
(3 weeks ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Thu, Jan 8, 2026, 02:08 PM

Monitoring

We have identified a possible fix that was deployed and we are now monitoring the impact.

Thu, Jan 8, 2026, 01:50 PM(18 minutes earlier)

Investigating

We are aware of the issues some users are experiencing where their server selections are not being taken into account. We are working on a fix.

Thu, Jan 8, 2026, 01:31 PM(18 minutes earlier)