No components marked as affected
Resolved
All issues resolved, you can go back to playing!
Monitoring
Our service provider has implemented a fix and we are monitoring the situation. We have opened the queues again for now.
Investigating
We are aware of issues with the platform.