Resolved
All issues resolved, you can go back to playing!
Monitoring
A fix has been rolled out and we are monitoring the current state. Queues have been reopened. Please update your game before playing!
Investigating
We're currently experiencing some technical issues with our CS2 integration, our team is working to resolve them as soon as possible.