CS2 Game Update Issues
Resolved·Full outage

All issues resolved, you can go back to playing!

Wed, Sep 17, 2025, 10:46 AM
(6 days ago)
·
Affected components
Play
Anti Cheat
Updates

Resolved

All issues resolved, you can go back to playing!

Wed, Sep 17, 2025, 10:46 AM

Monitoring

We have successfully updated both the FACEIT plugin and Anti-cheat, and queues have been re-opened. Thank you for bearing with us!

Wed, Sep 17, 2025, 08:37 AM(2 hours earlier)

Identified

Our team is progressing with the fix. The plugin integration issue has been resolved, and we are now addressing related issues with our Anti-Cheat system. Thank you for your patience — next update will be provided shortly.

Wed, Sep 17, 2025, 07:24 AM(1 hour earlier)

Investigating

We are aware of issues with the latest CS2 game update, and are looking into it. Queues are closed temporarily.

Tue, Sep 16, 2025, 11:38 PM(7 hours earlier)