Queue issues
Resolved·Partial outage

All issues resolved, you can go back to playing!

Tue, Sep 9, 2025, 02:11 PM
(1 week ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Tue, Sep 9, 2025, 02:11 PM

Monitoring

We have rolled out a fix and are monitoring the situation.

Tue, Sep 9, 2025, 01:55 PM(16 minutes earlier)

Investigating

We are aware of the issues when trying to queue up and are working on a fix.

Tue, Sep 9, 2025, 12:18 PM(1 hour earlier)