Resolved
All issues resolved, you can go back to playing!
Monitoring
We’ve released a new plugin version that addresses issues related to friendly fire and other tournament settings. Our team is continuing to monitor the situation to ensure everything is working as expected. Thank you for your patience and continued support.
Monitoring
We solved an issue that was pausing matches automatically. We’ve confirmed that new matches using the new version are no longer affected by the pause bug. Any further abuse of the pause bug or intentional friendly fire will result in a ban.
Monitoring
A fix has been deployed to production and is now live. All queues have been reopened, and our team is actively monitoring the servers for stability and any potential issues. We’ll continue to keep you updated as we ensure everything is running smoothly. Thank you for your patience and support.
Identified
Our team is still actively working on resolving the issue with the game plugin. We will provide another update within the next hour. Thank you for your patience and understanding.
Identified
The issue affecting our anti-cheat system has been resolved. However, we’re still working on fixing the game plugin integration. Thank you for your continued patience — we’ll share more updates as soon as they’re available.
Investigating
We're currently experiencing issues with our game integration and anti-cheat systems due to the latest game update. Our team is actively working to resolve the problem as quickly as possible. We appreciate your patience and will keep you updated as soon as we have more information.
Investigating
We've temporarily closed all queues to resolve an issue with matches not creating after the most recent CS2 update.