CS2 Game Update Issues
Resolved·Partial outage

All issues resolved as of 23:48 UTC, you can go back to playing!

Thu, Jul 3, 2025, 12:14 AM
(1 day ago)
·
Affected components
Play
Updates

Resolved

All issues resolved as of 23:48 UTC, you can go back to playing!

Thu, Jul 3, 2025, 12:14 AM

Investigating

We are aware of issues with the latest CS2 game update, and are looking into it.

Wed, Jul 2, 2025, 10:38 PM(1 hour earlier)