AC connectivity/reconnect Issues
Investigating·Degraded performance

Anti-cheat: We're currently experiencing issues with the Anti-Cheat system. Some players may experience connectivity/reconnect errors when connecting to Counter-Strike 2 game servers. We're investigating.

Tue, May 27, 2025, 07:59 PM
(1 day ago)
·
Affected components
Anti Cheat
Updates

Investigating

Anti-cheat: We're currently experiencing issues with the Anti-Cheat system. Some players may experience connectivity/reconnect errors when connecting to Counter-Strike 2 game servers. We're investigating.

Tue, May 27, 2025, 07:59 PM

Investigating

We are aware of issues with the platform.

Tue, May 27, 2025, 07:54 PM