All issues resolved, you can go back to playing!
Resolved
Monitoring
We have rolled out a fix and are monitoring the situation.
Investigating
Matchmaking is currently experiencing issues. We are aware of the problem and are working on a fix.
·