All NA MM matches default to Dust 2 in Chicago
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Fri, Feb 7, 2025, 04:20 AM
(3 months ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Fri, Feb 7, 2025, 04:20 AM

Investigating

We are aware of issues with the platform.

Thu, Feb 6, 2025, 10:51 PM(5 hours earlier)

Investigating

We are aware of issues with the platform.

Thu, Feb 6, 2025, 10:39 PM(12 minutes earlier)

Investigating

We are aware of issues with the platform.

Thu, Feb 6, 2025, 10:34 PM