Resolved
All issues resolved, you can go back to playing!
Monitoring
We have rolled out a fix and are monitoring the situation.
Identified
We have identified the issues and are working on a fix.
Investigating
We are aware that some users might experience long queue times.