Intermittent logouts
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Thu, Feb 6, 2025, 02:51 PM
(3 months ago)
·
Affected components
Play
Login
Updates

Resolved

All issues resolved, you can go back to playing!

Thu, Feb 6, 2025, 02:51 PM

Identified

We have identified the issues and are working on a fix.

Thu, Feb 6, 2025, 02:45 PM

Investigating

We are aware of issues with the platform and are currently investigate the root cause.

Thu, Feb 6, 2025, 01:53 PM(51 minutes earlier)