CS2 Game Update
Resolved·Partial outage

All issues resolved, you can go back to playing!

Wed, Jan 15, 2025, 11:08 AM
(4 months ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Wed, Jan 15, 2025, 11:08 AM

Monitoring

We have rolled out a fix and are monitoring the situation.

Wed, Jan 15, 2025, 09:44 AM(1 hour earlier)

Investigating

We've temporarily closed all queues to resolve an issue with matches not creating after the most recent CS2 update. Stay updated on the progress at: https://faceitstatus.com/ - Thanks for your patience.

Wed, Jan 15, 2025, 01:51 AM(7 hours earlier)