Resolved
All issues resolved, you can go back to playing!
Monitoring
We have rolled out a fix, and have have reopened the Matchmaking queues.
Identified
We have identified the issues and are working deploying the fix.
Investigating
We're currently experiencing some technical issues with our Counter Strike 2 integration following the latest CS2 game update. Our team is currently investigating them.