Clubs Navigation Issue
Resolved

All issues resolved, you can go back to playing!

Fri, Dec 6, 2024, 09:40 AM
(5 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

All issues resolved, you can go back to playing!

Fri, Dec 6, 2024, 09:40 AM

Investigating

We’re aware that Clubs are missing from the main navigation and user profiles and are actively investigating.

Fri, Dec 6, 2024, 06:54 AM(2 hours earlier)