Old version of the website shown to some users
Resolved

All users should now be able to access Faceit 2.0, please reach out through our support website if it's still an issue for you

Thu, Dec 5, 2024, 01:03 PM
(5 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

All users should now be able to access Faceit 2.0, please reach out through our support website if it's still an issue for you

Thu, Dec 5, 2024, 01:03 PM

Monitoring

Our monitoring shows that the number of users who couldn't access Faceit 2.0 has significantly reduced, but some users who use our Desktop Client or Opera browser might still be affected. If you still see old version of Faceit website, please try restarting the Desktop Client or browser. If problem remains and you still can't access Faceit 2.0, please reach out to us through our support website.

Wed, Dec 4, 2024, 10:54 AM(1 day earlier)

Monitoring

We have rolled out a fix and are monitoring the situation.

Tue, Dec 3, 2024, 08:22 PM(14 hours earlier)

Identified

We appreciate all the reports from users who were not been able to access Faceit 2.0 without force refreshing the page in the browser - we've identified the cause of this issue and working on resolving it

Tue, Dec 3, 2024, 04:03 PM(4 hours earlier)