Vote kick not working
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Tue, Nov 26, 2024, 05:03 PM
(9 months ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Tue, Nov 26, 2024, 05:03 PM

Monitoring

We have rolled out a fix and are monitoring the situation.

Tue, Nov 26, 2024, 04:37 PM(25 minutes earlier)

Investigating

We are aware of issues with the new vote kick feature not working properly in game. Our team is working on a fix.

Tue, Nov 26, 2024, 04:20 PM(17 minutes earlier)