Matchmaking page stays blank
Resolved·Partial outage

All issues resolved, you can go back to playing!

Thu, Nov 14, 2024, 11:51 AM
(6 months ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Thu, Nov 14, 2024, 11:51 AM

Monitoring

We have implemented a fix and are monitoring the platform.

Thu, Nov 14, 2024, 11:43 AM

Investigating

We are aware of issues with the platform. We are working on fixing the issue.

Thu, Nov 14, 2024, 11:33 AM