CS2 Game Update
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Fri, Oct 4, 2024, 07:45 AM
(7 months ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Fri, Oct 4, 2024, 07:45 AM

Monitoring

We have rolled out a fix, reopened all queues globally, and are monitoring the situation.

Thu, Oct 3, 2024, 04:11 PM(15 hours earlier)

Identified

We have identified the issues and are working on a fix.

Thu, Oct 3, 2024, 01:19 AM(14 hours earlier)