Resolved
All issues resolved.
Monitoring
All matchmaking queues have been reopened as Steam network appears to have stabilized.
Investigating
Steam network appears to have recovered.
We are giving it more time to ensure the Steam network is fully stable before reopening the matchmaking queues globally.
Investigating
CS2 Matchmaking - Steam is experiencing some instability issues, leading us to temporarily close the queues until this is resolved.
We appreciate your patience.