CS2 Update
Resolved·Partial outage

All issues resolved, you can go back to playing!

Thu, Aug 15, 2024, 06:57 AM
(9 months ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Thu, Aug 15, 2024, 06:57 AM

Monitoring

We have rolled out a fix and are monitoring the situation.

Thu, Aug 15, 2024, 12:14 AM(6 hours earlier)

Investigating

We've temporarily closed all queues to resolve an issue with matches not creating after the most recent CS2 update.

We are investigating the issue.

Wed, Aug 14, 2024, 09:56 PM(2 hours earlier)