Website Connectivity Issues
Resolved·Full outage

All issues resolved, you can go back to playing!

Fri, Aug 9, 2024, 04:00 PM
(8 months ago)
·
Affected components
Play
Login
Anti Cheat
Updates

Resolved

All issues resolved, you can go back to playing!

Fri, Aug 9, 2024, 04:00 PM

Monitoring

We have rolled out fixes as all systems are now operational. We will continue monitoring the performance.

All Counter-Strike 2 queues have been reopened.

Fri, Aug 9, 2024, 03:25 PM(35 minutes earlier)

Identified

The affected services are recovering successfully, as we are working on the total recovery.

All Counter-Strike 2 queues have been closed until all services are deemed to be fully operational.

Fri, Aug 9, 2024, 02:32 PM(52 minutes earlier)

Investigating

We are aware of the elevated issues across the platform's outage, our teams are looking into it.

Fri, Aug 9, 2024, 02:21 PM(10 minutes earlier)

Investigating

We are aware of issues with users being disconnected from the Anti-cheat client and are looking into it.

Fri, Aug 9, 2024, 01:51 PM(30 minutes earlier)