Resolved
We have rolled out a fix and see all queues back to normal, happy queueing!
Monitoring
We are seeing improvements in the queues, we are monitoring the situation. If you still encounter issues with your FACEIT play page being stuck in "queueing" please contact us.
Investigating
We are aware of the issue of some players getting a visual bug of being queued, despite not queueing - we are working on a fix.