CS2 AC issue
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Mon, Aug 5, 2024, 02:23 PM
(9 months ago)
·
Affected components
Anti Cheat
Updates

Resolved

All issues resolved, you can go back to playing!

Mon, Aug 5, 2024, 02:23 PM

Monitoring

We are still monitoring the AC fix and it seems fine. We have had reports of users having issues re-queuing, restarting your PC will fix this.

Mon, Aug 5, 2024, 02:20 PM

Monitoring

We have rolled out a fix and are monitoring the situation.

Mon, Aug 5, 2024, 01:45 PM(35 minutes earlier)

Identified

We are currently experiencing internal issues. Our team is actively working on a solution. We appreciate your patience and understanding during this time.

Mon, Aug 5, 2024, 01:37 PM