Matchmaking page loading issues
Resolved·Partial outage

Matchmaking page loading issue has been resolved, you can go back to playing!

Thu, Aug 1, 2024, 02:14 PM
(9 months ago)
·
Affected components
Play
Updates

Resolved

Matchmaking page loading issue has been resolved, you can go back to playing!

Thu, Aug 1, 2024, 02:14 PM

Monitoring

We have rolled out a fix and are monitoring the reports!

Thu, Aug 1, 2024, 02:00 PM(13 minutes earlier)

Investigating

We are aware of issues with the Matchmaking page not loading for certain users or regions, and are working on a fix.

Thu, Aug 1, 2024, 01:42 PM(18 minutes earlier)