CS2 - Issues post-CS2 game update
Resolved·Partial outage

All critical issues have been resolved and CS2 matches are operational.

Tue, Jul 23, 2024, 05:40 AM
(10 months ago)
·
Affected components
Play
Updates

Resolved

All critical issues have been resolved and CS2 matches are operational.

Tue, Jul 23, 2024, 05:40 AM

Monitoring

We have rolled out a fix and are monitoring the situation.

Tue, Jul 23, 2024, 02:19 AM(3 hours earlier)

Investigating

We've temporarily closed queues to investigate compatibility issues with the latest version of CS2 and the FACEIT CS2 server plugin

Tue, Jul 23, 2024, 12:42 AM(1 hour earlier)