CS2 - Issues post-CS2 game update
Resolved·Full outage

All issues have been resolved.

Please restart the FACEIT Anti-cheat client for an update and ensure you have updated your game to the latest version before playing.

Fri, Jun 21, 2024, 11:31 AM
(1 year ago)
·
Affected components
Play
Anti Cheat
Updates

Resolved

All issues have been resolved.

Please restart the FACEIT Anti-cheat client for an update and ensure you have updated your game to the latest version before playing.

Fri, Jun 21, 2024, 11:31 AM

Monitoring

We have rolled out a fix and are monitoring the situation.

Fri, Jun 21, 2024, 08:10 AM(3 hours earlier)

Identified

Due to recent Counter-Strike 2 updates, we have closed the queues to ensure the game's competitive integrity cannot be compromised in Matchmaking.

For third-party tournaments and event organizers, players can add +cl_input_enable_raw_keyboard 1 to the game's launch options as a temporary workaround.

We are actively working on resolving the issue and will provide updates as soon as possible.

Thank you for your understanding and patience.

Fri, Jun 21, 2024, 01:18 AM(6 hours earlier)

Identified

We have identified the issue and are working on resolving it.

Fri, Jun 21, 2024, 12:50 AM(27 minutes earlier)

Investigating

We've temporarily closed all queues to resolve an issue with the in-game movement issues after the most recent CS2 update.

We're actively working on the issue with our engineers.

Thu, Jun 20, 2024, 11:40 PM(1 hour earlier)