CS2 - Issues post-CS2 game update
Resolved·Full outage

All critical issues have been resolved and CS2 matches are operational.

Wed, Jun 12, 2024, 09:20 AM
(10 months ago)
·
Affected components
Play
Updates

Resolved

All critical issues have been resolved and CS2 matches are operational.

Wed, Jun 12, 2024, 09:20 AM

Identified

We are continuing to work on fixing the issue.

Wed, Jun 12, 2024, 01:45 AM(7 hours earlier)

Identified

We are continuing to work on fixing the issue.

Wed, Jun 12, 2024, 01:04 AM(40 minutes earlier)

Identified

We have identified the issues and are working on fixing them with our development team.

Wed, Jun 12, 2024, 12:30 AM(34 minutes earlier)

Investigating

We've temporarily closed all queues to resolve an issue with matches not creating with the latest game version after the most recent CS2 update.

We're actively working on the issue with our engineers.

Tue, Jun 11, 2024, 11:45 PM(44 minutes earlier)