CS2 - Issues post-CS2 game update
Resolved·Full outage

All issues have been resolved.

Wed, Jun 5, 2024, 12:18 PM
(11 months ago)
·
Affected components
Play
Updates

Resolved

All issues have been resolved.

Wed, Jun 5, 2024, 12:18 PM

Monitoring

We have fixed the issues, tested the fixes, and rolled it out across all servers.

All queues have been reopened.

Please ensure to have your game updated before queueing up.

Tue, Jun 4, 2024, 11:07 PM(13 hours earlier)

Identified

We have identified the issues and are working on fixing them.

We are hoping to have this resolved soon!

Tue, Jun 4, 2024, 10:47 PM(19 minutes earlier)

Investigating

We've temporarily closed all queues to resolve an issue with matches not creating with the latest game version after the most recent CS2 update.

We're actively working on the issue with our engineers.

Tue, Jun 4, 2024, 09:41 PM(1 hour earlier)