Anti-Cheat - ISP Routing issues
Resolved·Degraded performance

All routing issues seem to be resolved within the affected regions.

You can go back to playing!

Wed, May 29, 2024, 05:00 PM
(1 year ago)
·
Affected components
Anti Cheat
Updates

Resolved

All routing issues seem to be resolved within the affected regions.

You can go back to playing!

Wed, May 29, 2024, 05:00 PM

Identified

For a certain time period, users from the RU/Eastern Europe region were unable to log onto the FACEIT Anti-Cheat client or download it.

Wed, May 29, 2024, 04:15 PM(45 minutes earlier)

Investigating

We have detected reports of users from the Russian/Eastern EU ISPs experiencing certain routing issues with the Anti-Cheat client login and/or its download process.

Wed, May 29, 2024, 04:15 PM