Outgoing emails are delayed
Resolved·Partial outage

All issues resolved, you can go back to playing!

Mon, May 27, 2024, 02:24 PM
(1 year ago)
·
Affected components
Login
Updates

Resolved

All issues resolved, you can go back to playing!

Mon, May 27, 2024, 02:24 PM

Monitoring

We have rolled out a fix and are monitoring the situation.

Mon, May 27, 2024, 01:56 PM(27 minutes earlier)

Identified

We have identified the issues and are working on a fix.

Mon, May 27, 2024, 01:48 PM