All issues resolved, you can go back to playing!
Resolved
Identified
We have identified the issues and are working on a fix for our desktop client, meanwhile browser version can be used instead
Investigating
We are aware of issues with the platform.
·