CS2 - Issues post-CS2 game update
Resolved·Full outage

All issues resolved, you can go back to playing!

Wed, May 8, 2024, 08:59 AM
(1 year ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Wed, May 8, 2024, 08:59 AM

Monitoring

We have rolled out a fix and are monitoring the situation.

Wed, May 8, 2024, 08:24 AM(34 minutes earlier)

Identified

We have identified the issues and are working on a fix.

Wed, May 8, 2024, 07:38 AM(45 minutes earlier)

Identified

We have identified the issues and are working on a fix.

Wed, May 8, 2024, 07:29 AM

Investigating

We've spotted some new issues after deploying the fix and have begun investigating those.

All CS2 queues have been closed again until the mentioned issues have been resolved.

Wed, May 8, 2024, 02:53 AM(4 hours earlier)

Monitoring

The fix is confirmed to be working.

CS2 Queues have been reopened in all regions.

You can go back to playing!

Wed, May 8, 2024, 02:32 AM(20 minutes earlier)

Monitoring

The South Americas queue has been reopened.

We will continue monitoring the fix before reopening the queues globally.

Wed, May 8, 2024, 02:11 AM(20 minutes earlier)

Identified

The fix is being rolled out to all servers.

CS2 Queues will be reopened shortly, starting with the South Americas region.

Wed, May 8, 2024, 01:59 AM(12 minutes earlier)

Identified

We are continuing to work on fixing the issue.

Wed, May 8, 2024, 01:32 AM(26 minutes earlier)

Identified

We are continuing to work on fixing the issue.

Wed, May 8, 2024, 01:03 AM(29 minutes earlier)

Identified

We have identified the issues and are now working on a fix.

Wed, May 8, 2024, 12:29 AM(33 minutes earlier)

Investigating

We've temporarily closed all queues to resolve an issue with matches not creating with the latest game version after the most recent CS2 update.

We're actively working on the issue with our engineers.

Wed, May 8, 2024, 12:03 AM(26 minutes earlier)