CS2 - Issues post-CS2 game update
Resolved·Full outage

All issues resolved, you can go back to playing!

Wed, May 1, 2024, 09:48 AM
(1 year ago)
·
Affected components
Play
Anti Cheat
Updates

Resolved

All issues resolved, you can go back to playing!

Wed, May 1, 2024, 09:48 AM

Monitoring

We have rolled out a fix and are monitoring the situation.

Wed, May 1, 2024, 08:59 AM(48 minutes earlier)

Investigating

We are continuing to work on fixing & escalating the issue within our internal teams.

There is no ETA available at this time.

Wed, May 1, 2024, 12:18 AM(8 hours earlier)

Investigating

We've temporarily closed all queues to resolve an issue with matches not creating & game failing to start with Anti-Cheat client running after the most recent CS2 update.

We're actively working on the issue with our engineers.

Tue, Apr 30, 2024, 11:17 PM(1 hour earlier)