Problems loading www.faceit.com and accounts.faceit.com
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Tue, Apr 30, 2024, 04:31 PM
(1 year ago)
·
Affected components
Play
Login
Updates

Resolved

All issues resolved, you can go back to playing!

Tue, Apr 30, 2024, 04:31 PM

Identified

We have identified the issue and are working to remediate.

Tue, Apr 30, 2024, 04:30 PM

Investigating

We are aware of an issue that is impacting the FACEIT platform at the moment.

Tue, Apr 30, 2024, 04:15 PM(15 minutes earlier)