CS2 - Issues post-CS2 game update
Resolved·Full outage

All affected leftover matches from last night have been resolved/cancelled to allow the players to queue up for competitions and matchmaking.

All critical issues have been resolved and CS2 matches are operational.

Fri, Apr 26, 2024, 03:48 PM
(1 year ago)
·
Affected components
Play
Updates

Resolved

All affected leftover matches from last night have been resolved/cancelled to allow the players to queue up for competitions and matchmaking.

All critical issues have been resolved and CS2 matches are operational.

Fri, Apr 26, 2024, 03:48 PM

Monitoring

The necessary fixes have been deployed to all servers.

Matchmaking queues have been reopened globally and are now operational.

ACTIVE DUTY MAP POOL UPDATED: Added Dust2, Removed Overpass.

Fri, Apr 26, 2024, 02:00 PM(1 hour earlier)

Investigating

We are continuing to work on fixing the issue.

We aim to reopen the queues globally soon.

Fri, Apr 26, 2024, 01:30 PM(29 minutes earlier)

Investigating

We are continuing to work on fixing the issue.

The EU matchmaking queue has been temporarily reopened.

Fri, Apr 26, 2024, 12:14 PM(1 hour earlier)

Investigating

General Update:
All of our teams are continuing to work on fixing the issue. The queues cannot be reopened fully at this time.

Tournament Organizers & Creators:
Any and all CS2-related tournaments scheduled for today should be postponed until a later date until the issue has been resolved.

We will provide an update every hour.

Fri, Apr 26, 2024, 11:37 AM(37 minutes earlier)

Investigating

We are continuing to work on fixing the issue.

The SA matchmaking queue has been closed down again

Fri, Apr 26, 2024, 03:27 AM(8 hours earlier)

Investigating

We are continuing to work on fixing the issue.

The SA matchmaking queue has been temporarily reopened.

Fri, Apr 26, 2024, 03:02 AM(25 minutes earlier)

Investigating

We are continuing to work on fixing the issue.

Fri, Apr 26, 2024, 02:22 AM(39 minutes earlier)

Investigating

We've spotted some new issues after deploying the fix and have begun investigating those.

All CS2 queues have been closed again until the mentioned issues have been resolved.

Fri, Apr 26, 2024, 01:49 AM(33 minutes earlier)

Monitoring

The fix is confirmed to be working.

CS2 Queues have been reopened in all regions. You can go back to playing!

Fri, Apr 26, 2024, 01:18 AM(30 minutes earlier)

Monitoring

The fix has been rolled out to all servers.

CS2 Queues will be reopened shortly, starting with the North Americas region.

Fri, Apr 26, 2024, 01:12 AM

Identified

We are continuing to work on fixing the issue.

Fri, Apr 26, 2024, 12:59 AM(12 minutes earlier)

Investigating

We've temporarily closed all queues to resolve an issue with matches not creating with the latest game version after the most recent CS2 update.

We're actively working on the issue with our engineers.

Fri, Apr 26, 2024, 12:16 AM(42 minutes earlier)