FACEIT Client latest update and crash
Resolved
Lasted for 1h

All issues resolved, you can go back to playing!


If you are still having these Issues after fully restarting your Computer and the Anti-Cheat + FACEIT Client, please reinstall the Client from the Website.

Fri, Apr 19, 2024, 06:15 PM
1 month ago
Affected components

No components marked as affected

Updates

Resolved

All issues resolved, you can go back to playing!


If you are still having these Issues after fully restarting your Computer and the Anti-Cheat + FACEIT Client, please reinstall the Client from the Website.

Fri, Apr 19, 2024, 06:15 PM
1h earlier...

Identified

We are aware of the issue with the latest FACEIT Client update. While we work on the fix, the solution is to uninstall and re-install the the latest version from the website.

Fri, Apr 19, 2024, 05:08 PM